Table of Contents | ||
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Tablet fields: these are legacy fields which we planned to use for SimplyDelivery at the beginning of the project. We aren’t using these fields anymore.
Info |
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We will be removing the Tablet fields to declutter and simplify the UI. |
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E.g. Small menus need to be set as unavailable in the DOP. Sanity PLU configuration should not be used to manage availability.
🔍 Root cause analysis
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Product launch (07th March 2024)
Problem
BK DE has experienced a delay to make new products (HD BoGof) available on the App:
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After publish the Sanity document multiple times, the product was still not available on the App.
Root cause analysis
Based on our instructions, BK DE setup the PLUs as constant PLU under Vendor Configs:
SimplyDelivery Tablet fields:
SimplyDelivery Tablet
SimplyDelivery Tablet Delivery
Partner field set to Ignore;
BK DE reviewed the vendor configuration and didn’t find any error and the ticket was submitted
on Tech Support.Jira Legacy server System Jira serverId 255417eb-03fa-3e2f-a6ba-05d325fec50d key IREQ-1743 BK DE decided to delete the current Sanity document and re-created the documents with the same vendor config setup and the products were available on the App.
Sanity cache issue may cause the issue on products were not available on a short period of time.
After re-create a new Sanity document, the App took into consideration the new Document_ID.
Steps for solution
Address Sanity cache issue to engineer team start investigation: https://rbictg.atlassian.net/jira/servicedesk/projects/IREQ/queues/issue/IREQ-1859
Free products available (10th May 2024)
Problem
6 items were available to order for free in production.
Root cause analysis
It has been determined that the root cause of the issues stems from the following points:
those items were included in the CSV file with prices;
their PLU type was set to Ignore;
products that were not set as unavailable on the DOP.
To prevent such occurrences in the future, we should set the PLU for all itemsthat are included in the CSV and manage availability on DOP.
More details below:
After thorough investigation, we identified the issue started on the CSV Upload file.
We found that the products that were not supposed to be orderable were actually included in the CSV file with a price, and then set as Ignore in Sanity.
This meant that when the CSV was uploaded, those items were set as available with the price included in the CSV. However, as the PLU type of those items in Sanity was set to Ignore, our platform considered that these items should be ‘Ignored’ and priced at 0.00.
Additionally, these items couldn’t be manually disabled in the DOP Editor also because the PLU was set to Ignore. We have since changed this DOP behavior to prevent this situation.
One example:
Chicken Chili Cheese (Sanity ID item_53178) https://prod-bk-menu.de.rbi.tools/desk/orderLevelContent;menu;item;item_53178
It was set as Ignore in Sanity which was displayed as price 0.00, because this product was not set as unavailable on the DOP. We updated this product, set a random PLU 123456 and then we are able to make it unavailable on the DOP for all stores.
As a result, this item is available on the Static Menu, however since the user selects a specific store, this item is not available and the user will get a message to inform this behaviour.