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Conversion events for Memberships

Event Name

Description

Properties

Property Description

Membership Account Linked Successfully

The user has linked the membership successfully in the App. This means that:

  1. User successfully linked membership within RBI App.

  2. The Membership Offer is assigned and available for the user.

createdTime

membership

rbiCognitoId

Membership Account Link Failure

There was an error with linking the membership to the user’s account in the app. Please check the root cause property to understand the error.

e.g. user ID incorrect,

createdTime

membership

rbiCognitoId

root cause

Root Causes:

  • An error happened while verifying if the User can be linked

    • We had an error communicating with Blue Light Card API

  • The User is not linkable

    • Blue Light Card answers to our service that the user has the account inactive or cannot be linked

  • Membership Offer already assigned to the guest account

    • The user is trying to link again the account without redeeming the offer that he got from the last link

  • Membership Offer not configured correctly

    • There is a problem with the Membership Offer configuration on Sanity

  • Failed to assign the membership offer to the guest account

    • There is some error when assigning the offer

  • An unknown error happened while trying to link the account

    • We had an error that isn’t any of the above

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